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WHAT IS “BREKEL POINTCLOUD” 

 

 

 

“Brekel PointCloud” is a Windows application that enables 3D animators to record 3D PointCloud data using a 

Microsoft Kinect sensor at 30 frames per second and export them to popular mesh- and particle-cache 

formats. 

Internally tracking is done using the Microsoft Kinect SDK. 

 

It is written by Jasper Brekelmans, so in case you’re wondering that’s what “Brekel” refers to. 

“Brekel” is pronounced as “Break–uhl”. 

  



REQUIREMENTS 

 - Kinect for Windows or Kinect for XBox sensor 

- Power supply for the Kinect sensor 

 - Microsoft Windows 7 or higher 

 - 32 bit (x86) or 64 bit (x64) processor 

 - Core i5 or i7 CPU 

 - Dedicated USB 2.0 (or 3.0) bus 

 - 8 GB RAM or more 

 - Graphics card with OpenGL support 

 

A Kinect for Windows sensor will also support ‘near mode’ allowing capture as close to 40 cm from the sensor, 

the minimum distance for a Kinect for Xbox sensor is 80 cm. 

 

The Kinect for Windows sensor also supports control of the color camera settings like auto exposure, 

whitebalance etc. 

 

Note: when you bought your Kinect for Xbox separately you should have a separate power supply. 

If you’ve bought it bundled with an Xbox360 game console you need to buy a separate power supply, USB only 

will not be enough. 

  



 

INSTALLATION 

 

In order for “Brekel Kinect Pro PointCloud” to work you will need to have the Microsoft drivers installed for 

your Kinect sensor. If you’ve got a different set of Kinect drivers installed (OpenNI, OpenKinect or CLNui for 

example) please first uninstall them. 

(Note that the free “Brekel Kinect” application uses the OpenNI drivers) 

 

The installer should have taken care of installing the drivers already but in case you want more details: 

 

Please consult the following page for driver download and installation help: 

http://www.microsoft.com/en-us/kinectforwindows/develop/developer-downloads.aspx 

 

Kinect for Xbox sensors will ONLY work with the full SDK 

 

 

Kinect for Windows sensors will work with the full SDK as well as the runtime (which is smaller to download) 

 

 

  

http://www.microsoft.com/en-us/kinectforwindows/develop/developer-downloads.aspx


LICENSING 

 

With your purchase you should have received a download link for the retail version of the software and an 

email with your license code. (Please allow up to 24 hours for processing your request and double check your 

spam filter) 

 

The retail version will work immediately and with no restrictions even without a valid license, but will need 

activation within 5 days for continuous operation. 

 

You can activate your copy by using the “File > Install License” option from the menu. 

 

 

It will ask you to browse for your license file (which was attached to the mail). 

The license will automatically be copied to your “C:\ProgramData” folder and be active upon restart of the 

application. 

 

To display the current license info use the “File > Show License Info” option from the menu to display a 

window like the following: 

 

  



THE MAIN INTERFACE 

 

The application can function in a “Live” and a “From File” mode which can be switched from the tabs just 

above the main 3D viewport. 

 

In “Live” mode 3D PointCloud data from the Kinect sensor is visualized and can be recorded to disk in the .BKF 

(Brekel Kinect File) format. This format is designed to be as efficient as possible. 

 

 

In “From File” mode .BKF files can be loaded and converted to the available mesh- and particle cache formats. 

At the same time the color data can be exported to AVI movie files or various image texture formats. 

 

Depending on the chosen formats and available CPU and disk speed this process is usually not fast enough to 

be handled in realtime. Therefore this is handled offline so the recording can be as fast as possible. 

 

For navigation in the 3D views: 

- Left mouse button for orbit 

- Middle mouse button for dolly 

- Right mouse button for drag 

- Mouse wheel for dolly 



LIVE MODE 

 

In Live mode Video and Depth data is collected from the sensor at a resolution of 640x480 and at 30 frames 

per second. 

  

 

With the “PointCloud”, “Video” and “Depth” tabs just above the visualization window you can choose how to 

visualize the data. Note that on slow machines displaying full 3D “PointClouds” may be slower to draw than 

“Video” or “Depth”. 

 

Below the 3D view the audio (coming from the built in microphones) is displayed as a waveform. 

  



 

FPS 

Indicates the framerate of the data, this should roughly be 30 fps, if it’s lower you may be dropping frames. 

Low frame rates during recording may be due to CPU and/or disk speed. 

Low frame rates when not recording may be due to CPU or graphics card speed. 

You can try switching the visualization to either “Video” or “Depth” in these cases. 

 

Draw Floor 

Toggles displaying the floor grid in the 3D PointCloud visualization. 

 

Extended Depth 

When turned ON it uses the full available range (in depth) that the Kinect is capable off. 

This is from about 40cm to about 10 meters on both a Kinect for Xbox and Kinect for Windows sensor. 

Note that data will become noisier very close and very far away from the sensor. 

 

Near Mode (only available on Kinect for Windows devices) 

When turned ON the Kinect will senses depths roughly between 40cm and 3 meters from the sensor. 

When turned OFF the Kinect will senses depths roughly between 80cm and 4 meters from the sensor. 

 

Camera Settings (only available on Kinect for Windows devices) 

Opens a floating window that allows control over Exposure and Color settings, useful when working in low light 

situations or when you want manual control instead of automatically adjusting settings. 

  



 

Calibrate Sensor Position/Rotation 

Using this button you can calibrate the software so the pointcloud and tracking is adjusted for a sensor that is 

tilted up or down and adjust for the height of the sensor from the ground. 

 

First set the desired tilt using the slider on the right of the 3D view, make sure you are fully in view. 

During calibration the tilt motor will be adjusted so the sensor is horizontal. 

The lowest visible point will then be measured and be used to estimate the sensor’s height from the ground. 

The tilt motor will then be adjusted back to the previously set angle. 

Angle estimation is done using the sensor’s internal accelerometer. 

 

Sensor Pos 

Adjusting these XYZ values will translate the pointcloud and resulting skeleton, the main value of interest is the 

Y value depicting the height of the sensor above the ground. 

These values will be filled out by the automatic calibration, but can also be changed manually. 

 

Sensor Rot 

Adjusting these XYZ values will rotate the poitncloud and resulting skeleton, which can be of use when the 

sensor is tilted. 

These values will be filled out by the automatic calibration, but can also be changed manually. 

 

Reset Sensor Calibration 

Resets the Sensor Position and Rotation values back to 0 

 

 

 



 

 

Available Devices 

List the available audio devices that can be used for recording and allows you to select one of them. 

 

Number of Channels 

Switches between Mono and Stereo recording. 

 

Sampling Rate 

Sample rate to record (in Hz). 

 

Sample Size 

Amount of bits (8 or 16) used for recording. 

 

Note that audio is always recorder in the WAV format. 

  



 

Recording Info 

During and after recording this will display the amount of seconds recorded, theamount of frames recorded, 

the size of the recorded .BKF file and the speed (in Mb/sec) at which it could be written to disk. 

 

  



 

 

Start/Stop Recording 

Starts or Stops the recording of the .BKF and .WAV files. 

 

Output File 

Indicates where the .BKF file is saved, note that the .WAV file will be placed in the same folder and will have 

the same base name. 

 

Browse 

Brings up a file browser allowing the user to specify where the BKF file will be saved. 

 

 

Tilt Angle slider 

Use this to adjust the sensor’s tilt motor to point the viewing direction up or down. 

After making adjustments it’s best to hit the Calibrate Sensor Position/Rotation button again so the PointCloud 

and skeletons can be adjusted automatically. 

 



FROM FILE MODE 

 

 

 

In From File mode previously recorded .BKF files (Brekel Kinect File) can be loaded and exported to the various 

mesh cache, particle cache and texture output file formats. 

Depending on the chosen format(s) and available CPU and disk speed this is a process that can take a bit of 

time and it is therefore done as a post process. 

 

Note that Brekel Kinect Pro Body and Brekel Kinect Pro Face have the option of recording a BKF file at the 

same time as tracking the body or face. 

  



 

You can switch visualization in the 3D viewport to be drawn as points or triangles. 

Points can be faster on some graphics cards and has the advantage of showing the point density. 

Triangles are solid and without gaps and they have the advantage of visualizing the Stretch Threshold 

parameter for the Geometry Output. 

 

Draw Floor 

Toggles showing the floor grid in the 3D view. 

 

You can also switch to the Video and Depth views to inspect them. 

Note that there may be some pixel-distortion in the Video, this is done to match the Depth view and 

compensate for the Video and Depth sensor being in slightly different physical locations. This is correct and 

should make things align when used together. 

  



 

 

Frame 

After loading a file this allows you to scrub through the recorded sequence. 

 

Input File 

Allows you to specify a previously recorded BKF file (Brekel Kinect File) to use as a source. 

 

Output Folder 

Allows you to specify an output folder for the various export formats. 

Note that subfolders will automatically be created for the export formats that consist of file sequences. 

When no output folder is specified the folder where the input file resides will be used. 

 

Start/End/Frame 

Depicts which range of the timeline will be exported. 

 

Reset Start/End 

Resets the Start & End so the all the available frames will be used for export. 

 

Set Current as Start / Set Current as End 

Sets the current frame as the Start or End frame. 

 

Start/Stop Export 

Will go through the specified frames and export to all the selected formats. 

The process can be aborted by hitting the button during the export. 

A warning will be shown if there is a risk of overwriting previous files. 

 

Note that the separate black console window will print information on what is exported where. 



GEOMETRY OUTPUT 

 

Decimate 

Values higher than 1 reduce the detail by skipping points. A value of 2 will only use every other point, a value 

of 3 only every third etc. 

This will be done for both particle and mesh output 

  

  

 

Export Scale 

The scale of the output mesh/particles. 

 

 

 

 



 

Allows the export to various popular mesh cache file formats, note that these meshes will have different point 

and triangle counts per frame. Note that meshes will contain UVs that are designed to work with the textures 

that can also be exported. 

 

Stretch Threshold 

This option will filter out triangles that are stretched in depth above the specified threshold. 

A value that is too high may incorrectly connect objects close to the sensor to those far away from it. 

A value that is too low may create small holes in the mesh. 

 

Notice especially the arms and hands in the following example: 

   

 

  



Realflow BIN 

Exports meshes to a sequence of Realflow BIN files. 

You can download free “Connectivity Plug-ins” for 3DSMax, Maya, Softimage, Houdini, Lightwave, and 

Cinema4D from the Realflow website. A direct link to their site can be found under the Help menu. 

 

Alembic 

Exports meshes to a single Alembic file. 

More and more 3D packages support this popular format (Maya, Modo and Nuke for example) but free and 

commercial plugins also exist. You can find links to some of these plugins under the Help menu. 

 

Alembic Compression 

Alembic files can be compressed (lossless) to save disk space, this sets the level of compression. 

Higher values produce smaller files but will be slower to export and use more CPU power. 

 

OBJ sequence 

Exports meshes to a sequence of Wavefront OBJ files. 

These files can be read by most 3D packages, but few packages are designed to handle sequences of OBJ files 

efficiently. 

 

PLY sequence 

Exports meshes to a sequence of PLY files. 

 

U/V buttons 

Allow flipping of the U and/or V channel, experiment what your 3D package prefers. 

 

Texture/Colors 

Specifies to export (depending on file format support) the video colors as 

- None, don’t export them at all to keep file sizes smaller 

- Texture Coordinates, also known as UV coordinates so you can map the texture output automatically 

- Vertex Colors, as embedded colors saved per vertex 

  



PARTICLE OUTPUT 

 

Compression 

Compression creates smaller files, does not decrease quality, at the expense of writing speed. 

 

Colors 

Writes video colors as per-particle colors for the formats that support it 

 

Realflow BIN 

Exports particles to a sequence of Realflow BIN files. 

You can download free “Connectivity Plug-ins” for 3DSMax, Maya, Softimage, Houdini, Lightwave, and 

Cinema4D from the Realflow website. A direct link to their site can be found under the Help menu. 

 

BGEO 

Exports particles to a sequence of BGEO files, only for use in Houdini versions lower than v12. 

 

PDB 

Exports particles to a sequence of PDB files, for use in Maya and/or other programs. 

 

 



PDC 

Exports particles to a sequence of PDC files, for use in Maya. 

 

PRT 

Exports particles to a sequence of PRT files, for use in Krakatoa. 

 

PTC 

Exports particles to a sequence of PRT files, for use with Renderman and compliant renderers. 

 

PCD 

Exports particles to a sequence of PCD files, for use with the Point Cloud Library programming SDK. 

  



TEXTURE OUTPUT 

 

Video (AVI) 

Toggles if the video data should be exported to disk in the AVI movie format. 

 

Ask for codec 

When turned ON the program will ask which codec to use for the AVI file. (Available codecs will depend on 

what is installed on your system) 

When turned OFF the XVID codec will automatically be used. Since it has a nice tradeoff of quality, filesize and 

speed. 

If you’re having trouble with codecs I can recommend the K-Lite codec pack and/or Xvid: 

http://www.codecguide.com/download_kl.htm 

http://www.xvid.org/ 

Remember to also install the x64 version of the codec if you’re using the x64 version of Brekel Kinect Pro 

PointCloud. 

  

http://www.codecguide.com/download_kl.htm
http://www.xvid.org/


JPG 

Exports color information to a sequence of Jpeg files. 

 

PNG 

Exports color information to a sequence of PNG files, optional Compression is lossless. 

 

TGA 

Exports color information to a sequence of TARGA files, optional Compression is lossless using the RLE 

algorithm. 

 

TIFF 

Exports color information to a sequence of TIFF files, optional Compression is lossless using the Deflate 

algorithm. 

 

OpenEXR 

Exports the depth channel as greyscale images in the OpenEXR file format. 

 

Compressed 

Turns on compression for each format to keep the files as small as possible on disk. 

 

 

  



CROPPING 

 

Cropping allows for cropping the sides off to potentially clean background data that is not needed. 

Cropping is optional, when it’s turned on a red box is drawn in the 3D window visualizing the bounding box of 

the data that is saved. Any points outside of this box will not be drawn and exported. 

 

Reset 

Sets the bounding box to the current bounds of the PointCloud 

 

XYZ Min/Max 

Sets the size of the bounding box as visualized in the 3D window and used during export. 

  



TRANSFORM 

 

 

Allows for the pointcloud to be translated, rotated and scaled on each individual axis. 

Note that internally this is done before any cropping is applied, so you can straighten out a rotated pointcloud 

so it’s nicely aligned for the cropping box.  



SYSTEM INFO 

 

Shows how much Memory and CPU power is currently used and how much disk activity (writing only) is used. 

 

Note that the OS may do additional write buffering, so even though the frames are reported to be exported in 

the background the OS may still be writing them to disk. 

This explains why the Disk activity can be high for a few more seconds after the export is done, and why 

memory builds up during export since the OS is buffering things behind the scenes. 

 

Even if you exit Brekel Kinect Pro PointCloud the buffers will be correctly saved by the OS. 

  



TOP MENU 

File > Install License 

Let’s you browse to a license file and installs it to be used for the next time the application is run. 

 

File > Show License Info 

Shows if a license is installed and who it belongs to. 

 

File > Exit 

Saves settings and exits the application (same as clicking the X in the top right corner) 

 

  



Settings > Check for new version on start 

Will check online if a new version is available and lets the user know if there is one. 

 

Settings > Use Multi Threading 

When turned ON does more processing in parallel for multi-core/multi-cpu machines. 

Note that depending on your machine’s configuration, and especially the amount of available cores and their 

speed, this may be faster or slower. 

 

Settings > Tweak Sleep Time (advanced users) 

Internally processing is done on multiple threads, when no new data is available these threads go to sleep for a 

few milliseconds until they request new data. 

Advanced users may want to tweak this setting to gain a few FPS on slower machines, or gain responsiveness 

on faster machines that still have CPU time to spare. 

Note that bumping this too high will force evaluation to run at speeds lower than 30 FPS and therefore drop 

frames. 

  



Window > Dark Skin 

Toggles between the regular style (light) GUI and the dark style. 

 

Window > System Info 

Toggles visibility of the “System Info” dock. 

  



Help > Open Help File (PDF) 

Opens this help file, which can also be found in the installation folder. 

 

Help > Open Downloads Page 

Opens the standard web browser and directs it to the webpage with the latest installer downloads. 

 

Help > Open Forums 

Opens the standard web browser and directs it to the user forums. 

 

 

Additionally you can find links to plugins for various 3D packages that can read the Realflow and Alembic file 

formats. 

  



COMMANDLINE OPTIONS 

Advanced users can use one or more of the following commandline options: 

 

-sensorId 0 

In case you have multiple sensors connected to one machine you can specify which one to use by changing the 

value of 0 to a higher number. (note that this currently cannot be set from the GUI) 

 

-noVBO 

Adding this will force the rendering to not use any Vertex Buffer Object optimizations, which may cause 

problems on certain graphics cards and/or drivers. (note that this currently cannot be set from the GUI) 

 

-elevationAngle 0 

Sets the device’s tilt angle to the chosen value, valid range is from -27 to +27 

 

-nearMode 0 

0 turns nearMode OFF 

1 turns nearMode ON (Kinect for Windows devices only) 

 

-sleeptime 5 

Sets how many milliseconds the internal threads will wait before they check for fresh data. 

 

-multiThreading 

Forces multi threading to be used wherever possible. 


